Linmodems Mailing list Archives

Google
 
Web archives.linmodems.org

Return-Path: <jimmyhomcca@myjaring.net>
Mailing-List: contact discuss-help@linmodems.org; run by ezmlm
Delivered-To: mailing list discuss@linmodems.org
Received: (qmail 11169 invoked from network); 25 Apr 2004 22:24:56 -0000
Received: from desk.crynwr.com (65.172.240.34)
  by www.linmodems.org with SMTP; 25 Apr 2004 22:24:56 -0000
Received: (qmail 2419 invoked by uid 500); 25 Apr 2004 22:24:55 -0000
Received: (qmail 10253 invoked from network); 25 Apr 2004 22:14:09 -0000
Received: from smtp5.jaring.my (61.6.32.55)
  by www.linmodems.org with SMTP; 25 Apr 2004 22:14:09 -0000
Received: from myjaring.net (j191.mlk50.jaring.my [61.6.182.205])
	by smtp5.jaring.my (8.12.10/8.12.10) with ESMTP id i3PMDxUF026208
	for <discuss@linmodems.org>; Mon, 26 Apr 2004 06:14:00 +0800 (MYT)
	(envelope-from jimmyhomcca@myjaring.net)
Message-ID: <408C38B2.2080908@myjaring.net>
Date: Mon, 26 Apr 2004 06:16:18 +0800
From: Hor Jiun Shyong <jimmyhomcca@myjaring.net>
User-Agent: Mozilla Thunderbird 0.5 (Windows/20040207)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: discuss@linmodems.org
Subject: LTmodem driver problems on Linux implementation of  Lucent winmodem
 on IBM Thinkpad
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

Dear Linmodem administrator,

I have tried installing LTmodem driver on Linux implementation of 
Lucent winmodem on IBM Thinkpad but was reported during the build_module 
session that my gcc version is too high (3.3) instead of the required 
2.9   Naturally the driver compiling effort failed.

Modem is Lucent Winmodem and is within the range of the driver.  Kernel
headers are present.
Kernel is 2.4.22-1.2115.npt 1   Fedora Core 1
Pentium3 600mhz with 386mb RAM..

Modem works on Win98.

Same distro was installed on Athlon 1.2gHz desktop and external Hayes 
Accura modem was detected and working.

Thanks.



Below are the error messages

> Next checking utilty versions,
>            Version_min
>  Utility    or range for kernels
>    name     2.2.16       2.4.18          Actual_version
> -------------------------------------------------------------------
> Gnu C      2.7.2.3      2.95.3-2.9.99   3.3.2
> Gnu make   3.79.1       3.77            3.79.1
> binutils   2.8.1.0.23   2.9.1.0.25      2.14.90.0.6
>  
> -------------------------------------------------------------------
> Sorry, versions of 3 and greater are not yet compatible with the source code.
> While the compilation may will succeed, the drives most likely will not be functional.
> Aborting with Ctrl-C is RECOMMENDED. But to continue:
> Enter
>  
>         To begin compilation of lt_modem.o and lt_serial.o,  Enter
>  
> gcc -D__KERNEL__ -I/lib/modules/2.4.22-1.2115.nptl/build/include -Wall -Wstrict-prototypes -O3 -fomit-frame-pointer -fno-strict-aliasing -pipe -fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2 -DCPU=586 -DMODULE -DLT_VERSION=8.22a5 -DLINUX -DNO_EEPROM -DLT_SERIAL_MODULE=lt_serial -c -o ltmodem.a ltmodem.c
> `-m486' is deprecated. Use `-march=i486' or `-mcpu=i486' instead.
> cc1: warning: -malign-loops is obsolete, use -falign-loops
> cc1: warning: -malign-jumps is obsolete, use -falign-jumps
> cc1: warning: -malign-functions is obsolete, use -falign-functions
> ld -r -o lt_modem.o ltmodem.a ltmdmobj.o
> gcc -D__KERNEL__ -I/lib/modules/2.4.22-1.2115.nptl/build/include -Wall -Wstrict-prototypes -O3 -fomit-frame-pointer -fno-strict-aliasing -pipe -fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2 -DCPU=586 -DMODULE -DLT_VERSION=8.22a5 -DLINUX -DNO_EEPROM -DLT_SERIAL_MODULE=lt_serial -c -o serial-lt-2.4.a serial-lt-2.4.c
> `-m486' is deprecated. Use `-march=i486' or `-mcpu=i486' instead.
> cc1: warning: -malign-loops is obsolete, use -falign-loops
> cc1: warning: -malign-jumps is obsolete, use -falign-jumps
> cc1: warning: -malign-functions is obsolete, use -falign-functions
> serial-lt-2.4.c: In function `rs_close':
> serial-lt-2.4.c:2995: error: invalid operands to binary ==
> serial-lt-2.4.c: At top level:
> serial-lt-2.4.c:2585: warning: `rs_break' defined but not used
> make: *** [serial-lt-2.4.a] Error 1
>  
> Checking for driver products:
> -rw-r--r--    1 root     root       559481 Apr 25 07:17 lt_modem.o
>  
> Compilation of lt_serial.o failed,
> Do assess whether your utilities are up to date as listed within 1ST-READ!
> Read Compile_properly.txt from DOCs/.
> If you cannot solve the problem, send BLDrecord.txt to: discuss@linmodems.org
>  


Thanks.
-- 
Best Regards,
Hor Jiun Shyong ο

Webmaster: Russell Nelson
Last modified: Wed Jul 30 11:02:43 EDT 2003